Archives

G2T Premium 1.0.1.7

October 11, 2016 4:51 pm

Updates required for new PayPal security features, Woo Commerce 2.6.4 templates and php warnings showing during checkout.

Published by In