Error message instead of redirect after registration

June 14, 2014 8:05 pm

The plugin works once the registration is completed (ie, the GTW webinar shows the registrant and the registrant also receives the confirmation email). However, on the original registration page, a blank error page appears after the registration is submitted, instead of the re-direct to the page listed in the shortcode. This is the error:

Warning: in_array() expects parameter 2 to be array, null given in /home/cachc1/knhub.ca/wp-content/plugins/gotowp/gotowp_personal.php on line 272

Warning: Cannot modify header information – headers already sent by (output started at /home/cachc1/knhub.ca/wp-content/plugins/gotowp/gotowp_personal.php:272) in /home/cachc1/knhub.ca/wp-includes/pluggable.php on line 1121

Thanks in advance for your support. I’m hoping to get this working and use it a bit before considering the Premium upgrade.

Scott W

Published by 6 Comments

6 Replies

  • Hey Scott,

    Thanks for the post. We’ll take a look and get back to you. Hope you are having a nice weekend.

    Brandon

  • I get the same error, but only when I data to the additional fields beyond first and last name and email address (I have phone, organization, job title, and questions & comments).  If I just fill out the three required fields, then I’m OK.

    Thanks,

    Chuck

  • Hello Brandon,

    Will this issue be resolved if I purchase the Premium version of this plugin?  Everything seems to work – the registration info gets passed to GoToWebinar – but the redirect to a URL does not work.

    Also, on the embedded form, the required field designations to not appear, giving the impression that all fields are required or optional.

    Thanks,
    Chuck

  • Here is the error message I received:

    Warning: in_array() expects parameter 2 to be array, null given in /home/witric5/public_html/wp-content/plugins/gotowp/gotowp_personal.php on line 272

    Warning: Cannot modify header information – headers already sent by (output started at /home/witric5/public_html/wp-content/plugins/gotowp/gotowp_personal.php:272) in /home/witric5/public_html/wp-includes/pluggable.php on line 896

  • Hi Chuck,

    We are currently applying several updates we have made to the Premium and Woo versions back to the Free version. I hope to have those done within the next week or so. As a result, the code that is causing the issue you are experiencing with the Free has been improved for Premium and Woo. Keep your eyes posted for the Free update if you want to confirm it fixes what you are experiencing, but we are 99% confident it will.

    Thanks for your post and interest in the plugin and let me know if there is anything else I can help you with.

    Brandon

  • Thanks Brandon.  I am going to go ahead and get the Premium and test that out.

    Thanks,
    Chuck

Leave a Reply

Your email address will not be published.