Shortcode no longer works after upgrade

June 9, 2017 2:59 pm

I didn’t realize that upgrading the plugin would delete all of my settings and render my webinar registration form useless.
I tried to update my setting information and also updated the shortcode based on the suggestion in the plugin settings, but it still isn’t working. A generic registration form is showing, not linked to my webinar and the page is not redirecting to my thank you page. Please help asap as I’m losing registrations on my site.

Shortcode I am using:
[register_webinar type=single webid=7498356323813334273 pageid=3399]

Published by 5 Comments

5 Replies

  • Assuming you upgraded from Free version at to Premium version. If so, simply update shortcode from register_free_webinar to register_webinar and it should work. Also, we released update today for Premium that irons out a couple issues other users were having as well. Please test with register_webinar syntax as well as 2.1.4, if desired, and let us know. Thanks and have a great day!

  • My shortcode was in my original post and was generated by the plugin in the syntax that you mentioned. Still didn’t work. I’m using something else now, so please disregard.

  • Hi

    We are having the exact same issue as this using GoToWP Personal. The plugin updated, all of a sudden, none of our shortcodes worked, so we had to go through and update them all to the new version of the shortcode as described in the settings page.

    The forms are now correctly embedding, I have debugged through the code and I can see that it is correctly executing the API calls to get the correct form and being rendered on the page. However when the form is submitted and the gotowp_personal_registration_form_process function is called, there are two IF statements to determine how to process the form, however neither of them are matched and the function ends up finishing without doing anything.

    It appears the second IF statement is checking for card payments in order to process so that was not applicable in my case anyway, but the first one I believe is just checking for a form submission but it is checking the following:

    if (isset ( $_POST [‘group_wp’] ) && $_POST [‘group_wp’] == ‘webinar’ && isset ( $_POST [‘action’] ) && trim ( $_POST [‘action’] ) == ‘register_webinar’) {

    In my form, I have no attribute for group_wp at all and the action is set to register_webinar with no underscore.

    I have updated my version as below and it is now working:

    if (isset ( $_POST [‘action’] ) && trim ( $_POST [‘action’] ) == ‘registerwebinar’) {

    Is there a reason for this or is it a bug?

    Many thanks

  • In addition to my comments above, on further inspection, the forms are not actually submitting. This is due to the fact that the data is trying to be stored in a table called wplfa_gtwbundle_webinars before submitting via the API, however this table doesn’t exist.

    I am very concerned by the status of this, there seems to be major issues with this release. I was considering updating to the premium version but this doesn’t fill me with confidence.

    Many thanks

Leave a Reply

Your email address will not be published.