Woo Addon not registering at Gotowebinar

January 11, 2015 11:21 pm

After customer completes payment, they are not appearing in my gotowebinar account as registered.  Not sure where to look.

I’ve confirmed the webinar ID.  Do the dashes make a difference?

I currently have dashes.

I had successfully done a paid webinar in July.  Would the organizerkey or access token have changed?  I tried to refresh, but don’t see any change.

I use GOTOWP for WooCommerce Premium Woo .60

Published by 16 Comments

16 Replies

  • We have noticed that several keys / tokens seem to have expired this month so the first thing you may want to try is generating a fresh set at http://app.gotowp.com

    If that doesn’t work, let me know and we can take it from there.


  • I did regenerate the token key yesterday.

    I did have a purchase today and it didn’t register.

  • I tried again to regenerate the token and updated my plugin
    I’m using GotoWEBINAR (not GotoMeeting or GotoTraining).
    I refreshed the forms thing just in case.
    We’ll see as purchases come in today if the new ones register.

  • I can confirm that renewing the token again has not made an impact.
    WooCommerce to GotoWebinar isn’t registering people.

  • If I take the dashes out, I get a join now button, rather than the add to cart button.

  • Try entering the code at the end of the webinar link.  When you go to your GoToWebinar.com listing and open it… find the section that shows the Registration URL.  Example  https://attendee.gotowebinar.com/register/3699576615849012994

    and copy and paste the number sequence at the end of the URL in the Webinar Key within your particular product. for this example it would be:  3699576615849012994

    I was having this same issue and after updating tokens and using the above it resolved the issue.

    If it does not work post back here… Brandon is always a great help!

    Good Luck
    Kristi Stewart

  • That is because you are logged in and have already paid for the course.  Again I had this same thing going on a few moments ago.

    To test you will have to add an additional test webinar (product) but you can use the same webinar key – to retest the purchase.

  • I did as you suggest.

    The add to cart button disappeared and I had the “join now” button that went to this link:

    I’ve reverted back to the webinar id.

  • You are seeing the ‘join now’ button rather than the ‘add to cart’ button because you are logged into the admin using the same email address used to test the purchase.  The system displays the ‘join now’ because gotowebinar only allows one registration per email address.

    In order to test the purchase’s registration feature you will have to add a test webinar in your products.  You can use the same webinar id you are currently using to ensure the registration is pushing all the way to the G2W registration system.  You will have to repeat this process until you successfully show the registration in the G2W system.

    You may also want to double check that you have both Virtual and Downloadable checked in your product set-up.

    I was having the exact same issues but generating a fresh token key corrected the issue 100%.  Have you retested the entire purchase process since updating the tokens?

    [quote author=”Brandon Muth”]We have noticed that several keys / tokens seem to have expired this month so the first thing you may want to try is generating a fresh set at http://app.gotowp.com If that doesn’t work, let me know and we can take it from there. Thanks![/quote]

  • @evangelismcoach – we have spoken with a few customers who have said Citrix has updated their platform from “legacy” to “global” and a couple have also noted that the URLs to their webinars have changed too. As a result, I would recommend 1) updating key / token (if you haven’t already) and 2) ensure you have the correct platform selected in the settings area


    @kstewart0976 – thanks 🙂

  • That has been done to no effect.  I changed the token a few times, tapped the update webinar forms, and still no effect.

    The current webinar I was selling is now over, but maybe next week, I can resume troublshooting with a test setup.

  • “current webinar I was selling is now over” –> are you trying to convert the live webinar to a recorded one? If so, GoToWebinar issues a new ID# for recordings that is different than the ID# they issue for live webinars. If that is the issue, simply update the ID# in the Woo Product and save it and the plugin will detect the webinar as a recording.

    If I’m completely misunderstanding the issue, please let me know and we can always discuss over the phone 🙂


  • No.  I was selling a live webinar.  That event is now over.  I am not selling access to the replay hosted by GTW.

    I was not having success in the connection between my store and gotowebinar as sales were going on prior to the live webinar.

  • Ok, sorry to hear that. Please feel free to email access details and I will take a closer look at what might be going on. Thanks

  • I discovered that the key is not the webinar id (the one with the dashes). It is the long set of digits in the webinar registration url.


    Share Your Webinar

    Invite Your Attendees

    Registration URL: https://attendee.gotowebinar.com/register/12345678901234567890
    Webinar ID: 136-450-107

    So therefore the key would be “12345678901234567890”.

  • Did you ever figure out the issue? I’m running into the same problem. I’m using the right registration key. I see that the registration form is showing up on checkout but once payment is completed the registrant doesn’t show up on GTW…

Leave a Reply

Your email address will not be published.